cve.bz

CVE-2014-4657

9.8 criticalEPSS 4.4%

Critical (9.8) in redhat ansible. EPSS 4.4% chance of exploitation in the next 30 days. Fixed in ansible 1.5.4.

The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
4.4% chance of exploitation in the next 30 days; higher than 91% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qg47-5px9-32g7PyPIansible<1.5.41.5.4
PYSEC-2020-199PyPIansible<1.5.41.5.4

References

Check your stackJSON