CVE-2014-3483
rubyonrails rails: no CVSS score yet. EPSS 4.2% chance of exploitation in the next 30 days. Fixed in activerecord 4.0.7, 4.1.3.
SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/quoting.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 4.x before 4.0.7 and 4.1.x before 4.1.3 allows remote attackers to execute arbitrary SQL commands by leveraging improper range quoting.
- EPSS
- 4.2% chance of exploitation in the next 30 days; higher than 90% of CVEs (scores of 2026-10-31)
- CWE
- CWE-89
- Published
- Modified
- Record from
- the NVD, synced
Affected
- rubyonrails:rails
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-r8fh-hq2p-7qhq | RubyGems | activerecord | >=4.0.0 <4.0.7 | 4.0.7 |
| GHSA-r8fh-hq2p-7qhq | RubyGems | activerecord | >=4.1.0 <4.1.3 | 4.1.3 |