CVE-2014-2065
jenkins jenkins: no CVSS score yet. EPSS 1.8% chance of exploitation in the next 30 days. Fixed in org.jenkins-ci.main:jenkins-core 1.532.2, 1.551.
Cross-site scripting (XSS) vulnerability in Jenkins before 1.551 and LTS before 1.532.2 allows remote attackers to inject arbitrary web script or HTML via the iconSize cookie.
- EPSS
- 1.8% chance of exploitation in the next 30 days; higher than 78% of CVEs (scores of 2026-10-31)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- jenkins:jenkins
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-fxj8-cqcp-3vgq | Maven | org.jenkins-ci.main:jenkins-core | >=1.533 <1.551 | 1.551 |
| GHSA-fxj8-cqcp-3vgq | Maven | org.jenkins-ci.main:jenkins-core | <1.532.2 | 1.532.2 |
References
- http://www.openwall.com/lists/oss-security/2014/02/21/2
- https://github.com/jenkinsci/jenkins/commit/a0b00508eeb74d7033dc4100eb382df4e8fa72e7
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2014-02-14
- http://www.openwall.com/lists/oss-security/2014/02/21/2
- https://github.com/jenkinsci/jenkins/commit/a0b00508eeb74d7033dc4100eb382df4e8fa72e7