CVE-2013-6415
rubyonrails: no CVSS score yet. EPSS 3.2% chance of exploitation in the next 30 days. Fixed in actionpack 3.2.16, 4.0.2.
Cross-site scripting (XSS) vulnerability in the number_to_currency helper in actionpack/lib/action_view/helpers/number_helper.rb in Ruby on Rails before 3.2.16 and 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via the unit parameter.
- EPSS
- 3.2% chance of exploitation in the next 30 days; higher than 88% of CVEs (scores of 2026-10-31)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- rubyonrails:rails
- rubyonrails:ruby_on_rails
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-6h5q-96hp-9jgm | RubyGems | actionpack | >=3.0.0 <3.2.16 | 3.2.16 |
| GHSA-6h5q-96hp-9jgm | RubyGems | actionpack | >=4.0.0 <4.0.2 | 4.0.2 |
References
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00079.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00080.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00081.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00082.html
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00003.html