CVE-2013-4491
rubyonrails: no CVSS score yet. EPSS 2.2% chance of exploitation in the next 30 days. Fixed in actionpack 3.2.16, 4.0.2.
Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/translation_helper.rb in the internationalization component in Ruby on Rails 3.x before 3.2.16 and 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted string that triggers generation of a fallback string by the i18n gem.
- EPSS
- 2.2% chance of exploitation in the next 30 days; higher than 82% of CVEs (scores of 2026-10-31)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- rubyonrails:rails
- rubyonrails:ruby_on_rails
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-699m-mcjm-9cw8 | RubyGems | actionpack | >=3.0.0 <3.2.16 | 3.2.16 |
| GHSA-699m-mcjm-9cw8 | RubyGems | actionpack | >=4.0.0 <4.0.2 | 4.0.2 |
References
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00079.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00081.html
- http://lists.opensuse.org/opensuse-updates/2013-12/msg00082.html
- http://lists.opensuse.org/opensuse-updates/2014-01/msg00003.html
- http://rhn.redhat.com/errata/RHSA-2013-1794.html