CVE-2013-4363
No CVSS score yet. EPSS 1.7% chance of exploitation in the next 30 days. Fixed in rubygems-update 1.8.23.2, 1.8.27, 2.0.10.
Algorithmic complexity vulnerability in Gem::Version::ANCHORED_VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.2, 1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression. NOTE: this issue is due to an incomplete fix for CVE-2013-4287.
- EPSS
- 1.7% chance of exploitation in the next 30 days; higher than 77% of CVEs (scores of 2026-10-31)
- CWE
- CWE-310
- Published
- Modified
- Record from
- the NVD, synced
Affected
- ruby-lang:ruby
- rubygems:rubygems
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-9qvm-2vhf-q649 | RubyGems | rubygems-update | <1.8.23.2 | 1.8.23.2 |
| GHSA-9qvm-2vhf-q649 | RubyGems | rubygems-update | >=1.8.24 <1.8.27 | 1.8.27 |
| GHSA-9qvm-2vhf-q649 | RubyGems | rubygems-update | >=2.0.0 <2.0.10 | 2.0.10 |
| GHSA-9qvm-2vhf-q649 | RubyGems | rubygems-update | >=2.1.0 <2.1.5 | 2.1.5 |