CVE-2013-0269
rubygems json gem: no CVSS score yet. EPSS 14% chance of exploitation in the next 30 days. Fixed in json 1.5.5, 1.6.8, 1.7.7.
The JSON gem before 1.5.5, 1.6.x before 1.6.8, and 1.7.x before 1.7.7 for Ruby allows remote attackers to cause a denial of service (resource consumption) or bypass the mass assignment protection mechanism via a crafted JSON document that triggers the creation of arbitrary Ruby symbols or certain internal objects, as demonstrated by conducting a SQL injection attack against Ruby on Rails, aka "Unsafe Object Creation Vulnerability."
- EPSS
- 14% chance of exploitation in the next 30 days; higher than 96% of CVEs (scores of 2026-10-31)
- CWE
- CWE-20
- Published
- Modified
- Record from
- the NVD, synced
Affected
- rubygems:json_gem
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-x457-cw4h-hq5f | RubyGems | json | <1.5.5 | 1.5.5 |
| GHSA-x457-cw4h-hq5f | RubyGems | json | >=1.6.0 <1.6.8 | 1.6.8 |
| GHSA-x457-cw4h-hq5f | RubyGems | json | >=1.7.0 <1.7.7 | 1.7.7 |
References
- http://lists.apple.com/archives/security-announce/2013/Oct/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2013-04/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2013-04/msg00015.html
- http://lists.opensuse.org/opensuse-updates/2013-04/msg00034.html
- http://rhn.redhat.com/errata/RHSA-2013-0686.html