CVE-2012-1099
rubyonrails: no CVSS score yet. EPSS 2.4% chance of exploitation in the next 30 days. Fixed in actionpack 3.0.12, 3.1.4, 3.2.2.
Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_options_helper.rb in the select helper in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving certain generation of OPTION elements within SELECT elements.
- EPSS
- 2.4% chance of exploitation in the next 30 days; higher than 83% of CVEs (scores of 2026-10-31)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- rubyonrails:rails
- rubyonrails:ruby_on_rails
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-2xjj-5x6h-8vmf | RubyGems | actionpack | >=3.0.0 <3.0.12 | 3.0.12 |
| GHSA-2xjj-5x6h-8vmf | RubyGems | actionpack | >=3.1.0 <3.1.4 | 3.1.4 |
| GHSA-2xjj-5x6h-8vmf | RubyGems | actionpack | >=3.2.0 <3.2.2 | 3.2.2 |
References
- http://groups.google.com/group/rubyonrails-security/msg/6fca4f5c47705488?dmode=source&output=gplain
- http://lists.fedoraproject.org/pipermail/package-announce/2012-March/075675.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-March/075740.html
- http://weblog.rubyonrails.org/2012/3/1/ann-rails-3-0-12-has-been-released
- http://www.debian.org/security/2012/dsa-2466