CVE-2011-4953
cobbler project cobbler: no CVSS score yet. EPSS 2.2% chance of exploitation in the next 30 days. Fixed in cobbler 2.6.0.
The set_mgmt_parameters function in item.py in cobbler before 2.2.2 allows context-dependent attackers to execute arbitrary code via vectors related to the use of the yaml.load function instead of the yaml.safe_load function, as demonstrated using Puppet.
- EPSS
- 2.2% chance of exploitation in the next 30 days; higher than 82% of CVEs (scores of 2026-10-31)
- CWE
- CWE-20
- Published
- Modified
- Record from
- the NVD, synced
Affected
- cobbler_project:cobbler
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-hpj3-5p46-g87w | PyPI | cobbler | <2.6.0 | 2.6.0 |
| PYSEC-2026-793 | PyPI | cobbler | <2.6.0 | 2.6.0 |
References
- http://lists.opensuse.org/opensuse-security-announce/2012-04/msg00019.html
- https://bugs.launchpad.net/ubuntu/oneiric/+source/cobbler/+bug/858883
- https://bugzilla.novell.com/show_bug.cgi?id=757062
- http://lists.opensuse.org/opensuse-security-announce/2012-04/msg00019.html
- https://bugs.launchpad.net/ubuntu/oneiric/+source/cobbler/+bug/858883