CVE-2011-4319
rubyonrails: no CVSS score yet. EPSS 1.6% chance of exploitation in the next 30 days. Fixed in actionpack 3.0.11, 3.1.2.
Cross-site scripting (XSS) vulnerability in the i18n translations helper method in Ruby on Rails 3.0.x before 3.0.11 and 3.1.x before 3.1.2, and the rails_xss plugin in Ruby on Rails 2.3.x, allows remote attackers to inject arbitrary web script or HTML via vectors related to a translations string whose name ends with an "html" substring.
- EPSS
- 1.6% chance of exploitation in the next 30 days; higher than 75% of CVEs (scores of 2026-10-31)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- rubyonrails:rails
- rubyonrails:ruby_on_rails
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-xxr8-833v-c7wc | RubyGems | actionpack | >=3.0.0 <3.0.11 | 3.0.11 |
| GHSA-xxr8-833v-c7wc | RubyGems | actionpack | >=3.1.0 <3.1.2 | 3.1.2 |
References
- http://groups.google.com/group/rubyonrails-security/browse_thread/thread/2b61d70fb73c7cc5?pli=1
- http://groups.google.com/group/rubyonrails-security/msg/c65c24fbc4b6dd82?dmode=source&output=gplain
- http://openwall.com/lists/oss-security/2011/11/18/8
- http://osvdb.org/77199
- http://weblog.rubyonrails.org/2011/11/18/rails-3-0-11-has-been-released