CVE-2011-2932
rubyonrails: no CVSS score yet. EPSS 2.5% chance of exploitation in the next 30 days. Fixed in activesupport 2.3.13, 3.0.10.
Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails 2.x before 2.3.13, 3.0.x before 3.0.10, and 3.1.x before 3.1.0.rc5 allows remote attackers to inject arbitrary web script or HTML via a malformed Unicode string, related to a "UTF-8 escaping vulnerability."
- EPSS
- 2.5% chance of exploitation in the next 30 days; higher than 84% of CVEs (scores of 2026-10-31)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- rubyonrails:rails
- rubyonrails:ruby_on_rails
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-9fh3-vh3h-q4g3 | RubyGems | activesupport | >=2.0.0 <2.3.13 | 2.3.13 |
| GHSA-9fh3-vh3h-q4g3 | RubyGems | activesupport | >=3.0.0 <3.0.10 | 3.0.10 |
References
- http://groups.google.com/group/rubyonrails-security/msg/f1d2749773db9f21?dmode=source&output=gplain
- http://lists.fedoraproject.org/pipermail/package-announce/2011-September/065114.html
- http://lists.fedoraproject.org/pipermail/package-announce/2011-September/065189.html
- http://lists.fedoraproject.org/pipermail/package-announce/2011-September/065212.html
- http://secunia.com/advisories/45917