CVE-2011-1157
mark pilgrim feedparser: no CVSS score yet. EPSS 2.5% chance of exploitation in the next 30 days. Fixed in feedparser 5.0.1.
Cross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) 5.x before 5.0.1 allows remote attackers to inject arbitrary web script or HTML via malformed XML comments.
- EPSS
- 2.5% chance of exploitation in the next 30 days; higher than 84% of CVEs (scores of 2026-10-31)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- mark_pilgrim:feedparser
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-2p78-8hh6-96xc | PyPI | feedparser | >=5.0 <5.0.1 | 5.0.1 |
| PYSEC-2011-20 | PyPI | feedparser | <5.0.1 | 5.0.1 |