cve.bz

CVE-2011-10026

9.3 criticalEPSS 3.8%

Critical (9.3) in spreecommerce spree. EPSS 3.8% chance of exploitation in the next 30 days. Fixed in spree 0.50.0.

Spreecommerce versions prior to 0.50.x contain a remote command execution vulnerability in the API's search functionality. Improper input sanitation allows attackers to inject arbitrary shell commands via the search[instance_eval] parameter, which is dynamically invoked using Ruby’s send method. This flaw enables unauthenticated attackers to execute commands on the server.

Severity

CVSS 4.0

9.3 critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
3.8% chance of exploitation in the next 30 days; higher than 89% of CVEs (scores of 2026-10-31)
CWE
CWE-78
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-x485-rhg3-cqr4RubyGemsspree>=0.30.0.beta1 <0.50.00.50.0
GHSA-x485-rhg3-cqr4RubyGemsrd_searchlogic<=3.0.1no fix published

References

Check your stackJSON