CVE-2009-2940
pygresql pygresql: no CVSS score yet. EPSS 2.7% chance of exploitation in the next 30 days. Fixed in pygresql 4.1.
The pygresql module 3.8.1 and 4.0 for Python does not properly support the PQescapeStringConn function, which might allow remote attackers to leverage escaping issues involving multibyte character encodings.
- EPSS
- 2.7% chance of exploitation in the next 30 days; higher than 85% of CVEs (scores of 2026-10-31)
- Published
- Modified
- Record from
- the NVD, synced
Affected
- pygresql:pygresql
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-xv6x-43gq-4hfj | PyPI | pygresql | <=3.8.1 | no fix published |
| GHSA-xv6x-43gq-4hfj | PyPI | pygresql | >=4.0 <4.1 | 4.1 |
| PYSEC-2009-18 | PyPI | pygresql | >=3.8.1 <=4.0 | no fix published |