CVE-2008-2938
apache tomcat: no CVSS score yet. EPSS 100% chance of exploitation in the next 30 days. Fixed in org.apache.tomcat:tomcat 4.1.39, 5.5.27, 6.0.18.
Directory traversal vulnerability in Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16, when allowLinking and UTF-8 are enabled, allows remote attackers to read arbitrary files via encoded directory traversal sequences in the URI, a different vulnerability than CVE-2008-2370. NOTE: versions earlier than 6.0.18 were reported affected, but the vendor advisory lists 6.0.16 as the last affected version.
- EPSS
- 100% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-31)
- CWE
- CWE-22
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:tomcat
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-m7xj-ccqc-p4g2 | Maven | org.apache.tomcat:tomcat | >=4.1.0 <4.1.39 | 4.1.39 |
| GHSA-m7xj-ccqc-p4g2 | Maven | org.apache.tomcat:tomcat | >=5.5.0 <5.5.27 | 5.5.27 |
| GHSA-m7xj-ccqc-p4g2 | Maven | org.apache.tomcat:tomcat | >=6.0.0 <6.0.18 | 6.0.18 |
References
- http://lists.apple.com/archives/security-announce/2008/Oct/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2008-09/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2009-02/msg00002.html
- http://marc.info/?l=bugtraq&m=123376588623823&w=2
- http://secunia.com/advisories/31639