{"cve":"CVE-2026-9358","nvd":{"published":"2026-05-24T06:16:37.573","modified":"2026-07-23T11:10:00.120","status":"Deferred","description":"A vulnerability was determined in postcss-selector-parser up to 6.1.2/7.1.2. Affected is the function toString of the file src/selectors/container.js of the component AST Serialization. Executing a manipulation can lead to uncontrolled recursion. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 6.1.3 and 7.1.3 is able to address this issue. This patch is called 5bc698cef66f8abd12610dc623e5d67cbc0f869d. It is suggested to upgrade the affected component. The vendor explains, that according to his definition \"DoS on server-side on user-generated CSS is low risk for us (since most users compile own CSS with PostCSS).\" The commits were backported to 6.x branch, which was the most downloaded version.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","score":2.1},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L","score":4.3},"cwes":["CWE-404","CWE-674"],"references":["https://gist.github.com/bx33661/581e3a38134601c04e19b4dfc9b459b9","https://github.com/postcss/postcss-selector-parser/commit/5bc698cef66f8abd12610dc623e5d67cbc0f869d","https://github.com/postcss/postcss-selector-parser/releases/tag/7.1.3","https://vuldb.com/cve/CVE-2026-9358","https://vuldb.com/submit/813080"],"products":[],"source":"nvd","synced_at":"2026-10-19T22:36:28.938604137+00:00"},"epss":{"cve":"CVE-2026-9358","score":0.00325,"percentile":0.25604,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-w9m9-85wc-3x92","url":"https://osv.dev/vulnerability/GHSA-w9m9-85wc-3x92","summary":"postcss-selector-parser allows denial of service through uncontrolled AST recursion","modified":"2026-09-10T03:50:47.767644603Z","packages":[{"ecosystem":"npm","name":"postcss-selector-parser","purl":"pkg:npm/postcss-selector-parser","ranges":[">=6.1.0 <6.1.3"],"fixed":["6.1.3"]},{"ecosystem":"npm","name":"postcss-selector-parser","purl":"pkg:npm/postcss-selector-parser","ranges":[">=7.1.0 <7.1.3"],"fixed":["7.1.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}