{"cve":"CVE-2026-73626","nvd":{"published":"2026-08-13T12:17:27.897","modified":"2026-09-09T20:36:38.867","status":"Awaiting Analysis","description":"JupyterLab versions >=4.6.0,<=4.6.1 and <=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install(). A missing 'await' caused the is_install_allowed coroutine to never execute, so the extension allowlist/blocklist check was not enforced for direct callers of install(). The stock JupyterLab HTTP API and Extension Manager UI are not affected, as they perform a separate, correctly awaited check. The issue affects only deployments where a custom extension or downstream integration imports PyPIExtensionManager and calls install() directly with a package name influenced by untrusted input, an allowlist/blocklist is configured, the PyPI Extension Manager is enabled, and kernels and terminals are disabled or delegated to remote hosts. Fixed in JupyterLab 4.6.2 and 4.5.10.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","score":7.7},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","score":7.5},"cwes":["CWE-284"],"references":["https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-whvh-wf3x-g77j","https://www.vulncheck.com/advisories/jupyterlab-before-authentication-bypass-via-pypiextensionmanager"],"products":[],"source":"nvd","synced_at":"2026-10-19T22:48:17.459049833+00:00"},"epss":{"cve":"CVE-2026-73626","score":0.00363,"percentile":0.30121,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-whvh-wf3x-g77j","url":"https://osv.dev/vulnerability/GHSA-whvh-wf3x-g77j","summary":"JupyterLab: Allowlist/blocklist check in `PyPIExtensionManager.install()` not enforced for direct callers (missing `await`)","modified":"2026-09-25T14:25:48.030827903Z","packages":[{"ecosystem":"PyPI","name":"jupyterlab","purl":"pkg:pypi/jupyterlab","ranges":[">=4.6.0 <4.6.2"],"fixed":["4.6.2"]},{"ecosystem":"PyPI","name":"jupyterlab","purl":"pkg:pypi/jupyterlab","ranges":["<4.5.10"],"fixed":["4.5.10"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}