{"cve":"CVE-2026-73557","nvd":{"published":"2026-08-13T15:20:18.080","modified":"2026-10-15T20:42:47.637","status":"Analyzed","description":"vLLM is an inference and serving engine for large language models. From 0.20.2rc0 until 0.26.0, safe_load_prompt_embeds in vllm/renderers/embed_utils.py uses torch.sparse.check_sparse_tensor_invariants, whose process-global save, enable, and restore state can be raced by concurrent prompt_embeds parts submitted to POST /v1/chat/completions through AsyncMultiModalItemTracker.resolve_items, asyncio.gather, and the default executor, allowing an invalid sparse tensor to reach tensor.to_dense despite the CVE-2025-62164 guard when enable_prompt_embeds is enabled. This issue is fixed in version 0.26.0.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","score":6.3},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","score":5.3},"cwes":["CWE-362"],"references":["https://github.com/vllm-project/vllm/commit/793cf79c89d4049124e756915468ac30318f2e50","https://github.com/vllm-project/vllm/pull/48583","https://github.com/vllm-project/vllm/releases/tag/v0.26.0","https://github.com/vllm-project/vllm/security/advisories/GHSA-pr7f-p5mw-fc87"],"products":["vllm:vllm"],"source":"nvd","synced_at":"2026-10-19T22:48:17.459049833+00:00"},"epss":{"cve":"CVE-2026-73557","score":0.00247,"percentile":0.15881,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-pr7f-p5mw-fc87","url":"https://osv.dev/vulnerability/GHSA-pr7f-p5mw-fc87","summary":" vLLM: Incomplete CVE-2025-62164 remediation can be bypassed by concurrent prompt parts","modified":"2026-09-10T12:25:39.108374346Z","packages":[{"ecosystem":"PyPI","name":"vllm","purl":"pkg:pypi/vllm","ranges":[">=0.21.0 <0.26.0"],"fixed":["0.26.0"]}]},{"id":"PYSEC-2026-3938","url":"https://osv.dev/vulnerability/PYSEC-2026-3938","summary":" vLLM: Incomplete CVE-2025-62164 remediation can be bypassed by concurrent prompt parts","modified":"2026-09-10T12:15:13.662900860Z","packages":[{"ecosystem":"PyPI","name":"vllm","purl":"pkg:pypi/vllm","ranges":[">=0.21.0 <0.26.0"],"fixed":["0.26.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}