{"cve":"CVE-2026-7142","nvd":{"published":"2026-04-27T17:16:45.820","modified":"2026-06-17T11:01:54.957","status":"Deferred","description":"A vulnerability was determined in Wooey up to 0.13.2. The impacted element is the function add_or_update_script of the file wooey/api/scripts.py of the component API Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 0.13.3rc1 and 0.14.0 is sufficient to resolve this issue. This patch is called f7846fc0c323da8325422cab32623491757f1b88. The affected component should be upgraded.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","score":2.1},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","score":6.3},"cwes":["CWE-266","CWE-285"],"references":["https://github.com/wooey/Wooey/","https://github.com/wooey/Wooey/commit/f7846fc0c323da8325422cab32623491757f1b88","https://github.com/wooey/Wooey/issues/408","https://github.com/wooey/Wooey/pull/407","https://github.com/wooey/Wooey/releases/tag/v0.13.3rc1"],"products":[],"source":"nvd","synced_at":"2026-10-19T22:33:09.003606135+00:00"},"epss":{"cve":"CVE-2026-7142","score":0.00215,"percentile":0.11887,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-w65c-cmxj-qrhm","url":"https://osv.dev/vulnerability/GHSA-w65c-cmxj-qrhm","summary":"Wooey has an Incorrect Privilege Assignment issue","modified":"2026-07-13T16:43:20.359137021Z","packages":[{"ecosystem":"PyPI","name":"wooey","purl":"pkg:pypi/wooey","ranges":["<0.13.3rc1"],"fixed":["0.13.3rc1"]}]},{"id":"PYSEC-2026-3427","url":"https://osv.dev/vulnerability/PYSEC-2026-3427","summary":"Wooey has an Incorrect Privilege Assignment issue","modified":"2026-07-13T16:33:05.769479710Z","packages":[{"ecosystem":"PyPI","name":"wooey","purl":"pkg:pypi/wooey","ranges":["<0.13.3rc1"],"fixed":["0.13.3rc1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}