{"cve":"CVE-2026-59946","nvd":{"published":"2026-07-08T20:16:59.707","modified":"2026-07-10T19:14:18.563","status":"Deferred","description":"Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a Composer package bin entry containing .. path segments can resolve outside the package install directory and cause Composer's binary installation flow to chmod an existing host file to a world-readable and world-executable mode during composer install, update, or require. This issue is fixed in versions 2.2.29 and 2.10.2.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N","score":6.1},"cwes":["CWE-22","CWE-732"],"references":["https://github.com/composer/composer/commit/502c6c4f699802d9cf464728b3e8a95674f919a0","https://github.com/composer/composer/commit/c50b1efd13ebd73f6dca19b31424c5a02bf93cc1","https://github.com/composer/composer/releases/tag/2.10.2","https://github.com/composer/composer/releases/tag/2.2.29","https://github.com/composer/composer/security/advisories/GHSA-gjfg-22fp-rrxx"],"products":[],"source":"nvd","synced_at":"2026-10-19T22:42:16.820116992+00:00"},"epss":{"cve":"CVE-2026-59946","score":0.00141,"percentile":0.03402,"date":"2026-11-01"},"kev":null,"osv":[],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}