{"cve":"CVE-2026-48032","nvd":{"published":"2026-07-24T19:16:58.190","modified":"2026-10-24T13:10:00.147","status":"Deferred","description":"Hulumi is an open-source toolkit that ships secure-by-default cloud and platform infrastructure components for Pulumi. Prior to version 1.4.0, IAM-role policy checks can be bypassed when the role trusts multiple OIDC providers. This issue has been patched in version 1.4.0.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N","score":8.3},"cvss_v3":null,"cwes":["CWE-697"],"references":["https://github.com/kerberosmansour/hulumi/pull/178","https://github.com/kerberosmansour/hulumi/releases/tag/v1.4.0","https://github.com/kerberosmansour/hulumi/security/advisories/GHSA-g759-4pxw-6692"],"products":[],"source":"nvd","synced_at":"2026-10-24T16:53:27.712498749+00:00"},"epss":{"cve":"CVE-2026-48032","score":0.00538,"percentile":0.45007,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-g759-4pxw-6692","url":"https://osv.dev/vulnerability/GHSA-g759-4pxw-6692","summary":"@hulumi/policies bypasses IAM-role policy checks when the role trusts multiple OIDC providers","modified":"2026-09-10T03:50:49.425970508Z","packages":[{"ecosystem":"npm","name":"@hulumi/policies","purl":"pkg:npm/%40hulumi/policies","ranges":["<1.4.0"],"fixed":["1.4.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}