{"cve":"CVE-2026-47137","nvd":{"published":"2026-06-12T15:16:28.137","modified":"2026-10-26T11:10:00.157","status":"Deferred","description":"vm2 is an open source vm/sandbox for Node.js. Prior to version 3.11.4, the fix for GHSA-8hg8-63c5-gwmx (CVE-2023-37903) introduced a check in nodevm.js line 263 that blocks the combination nesting: true + require: false. However, the check uses strict equality (options.require === false), which is trivially bypassed by omitting the require option entirely. When require is not specified, options.require is undefined, not false. The strict equality check fails, so the security guard is skipped. Immediately after (line 280), the destructuring default require: requireOpts = false assigns requireOpts = false, producing the exact configuration the patch was designed to prevent. This issue has been patched in version 3.11.4.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","score":10.0},"cwes":["CWE-913"],"references":["https://github.com/advisories/GHSA-g644-9gfx-q4q4","https://github.com/patriksimek/vm2/commit/01a7552add345d5a6862623884e6b79a85bf0568","https://github.com/patriksimek/vm2/commit/86ab819f202c3a8dad88cef5705f2e416c5188d7","https://github.com/patriksimek/vm2/releases/tag/v3.11.4","https://github.com/patriksimek/vm2/security/advisories/GHSA-m4wx-m65x-ghrr"],"products":[],"source":"nvd","synced_at":"2026-10-26T11:33:08.859761529+00:00"},"epss":{"cve":"CVE-2026-47137","score":0.00382,"percentile":0.3189,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-m4wx-m65x-ghrr","url":"https://osv.dev/vulnerability/GHSA-m4wx-m65x-ghrr","summary":"vm2 has a CVE-2023-37903 patch bypass: nesting:true without explicit require still allows full RCE","modified":"2026-07-08T08:14:40.607171042Z","packages":[{"ecosystem":"npm","name":"vm2","purl":"pkg:npm/vm2","ranges":["<3.11.4"],"fixed":["3.11.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}