{"cve":"CVE-2026-47102","nvd":{"published":"2026-05-21T21:16:32.557","modified":"2026-10-08T16:17:17.247","status":"Modified","description":"LiteLLM prior to 1.83.10 allows a user to modify their own user_role via the /user/update endpoint. While the endpoint correctly restricts users to updating only their own account, it does not restrict which fields may be changed. A user who can reach this endpoint can set their role to proxy_admin, gaining full administrative access to LiteLLM including all users, teams, keys, models, and prompt history. Users with the org_admin role have legitimate access to this endpoint and can exploit this vulnerability without chaining any additional flaw.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","score":8.7},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-863","CWE-915"],"references":["https://gist.github.com/13ph03nix/9ec616e1fdc77b3673509c60206e827f","https://github.com/BerriAI/litellm/commit/128d32d2494b759c5d15da3452452af4c6a34c01","https://github.com/BerriAI/litellm/commit/e6f18ce75b111c9b93dc15c72894cbdeb53177ce","https://github.com/BerriAI/litellm/pull/25541","https://github.com/BerriAI/litellm/releases/tag/v1.83.10-stable"],"products":["litellm:litellm"],"source":"nvd","synced_at":"2026-10-19T22:36:28.938604137+00:00"},"epss":{"cve":"CVE-2026-47102","score":0.00654,"percentile":0.51029,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-wpfp-gwwc-vwq6","url":"https://osv.dev/vulnerability/GHSA-wpfp-gwwc-vwq6","summary":"LiteLLM allows a user to modify their own user_role via the /user/update endpoint","modified":"2026-09-10T03:50:47.941656453Z","packages":[{"ecosystem":"PyPI","name":"litellm","purl":"pkg:pypi/litellm","ranges":["<1.83.10"],"fixed":["1.83.10"]}]},{"id":"PYSEC-2026-2600","url":"https://osv.dev/vulnerability/PYSEC-2026-2600","summary":"LiteLLM allows a user to modify their own user_role via the /user/update endpoint","modified":"2026-07-13T16:32:04.301271937Z","packages":[{"ecosystem":"PyPI","name":"litellm","purl":"pkg:pypi/litellm","ranges":["<1.83.10"],"fixed":["1.83.10"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}