{"cve":"CVE-2026-46718","nvd":{"published":"2026-06-02T10:16:25.377","modified":"2026-07-22T19:10:00.120","status":"Analyzed","description":"Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite.\n\nThis issue affects Apache Calcite: from 1.5.0 before 1.42.\n\nUsers are recommended to upgrade to version 1.42, which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","score":6.5},"cwes":["CWE-470"],"references":["https://lists.apache.org/thread/9s37svo343w5ck1ovh478lkzcqk4949v","http://www.openwall.com/lists/oss-security/2026/06/01/7"],"products":["apache:calcite"],"source":"nvd","synced_at":"2026-10-19T22:37:48.043517290+00:00"},"epss":{"cve":"CVE-2026-46718","score":0.00436,"percentile":0.3786,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-c2rv-hwqm-wjpg","url":"https://osv.dev/vulnerability/GHSA-c2rv-hwqm-wjpg","summary":"Apache Calcite is Vulnerable to Use of Externally-Controlled Input to Select Classes","modified":"2026-09-10T03:51:08.417300277Z","packages":[{"ecosystem":"Maven","name":"org.apache.calcite:calcite-core","purl":"pkg:maven/org.apache.calcite/calcite-core","ranges":[">=1.5.0 <1.42.0"],"fixed":["1.42.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}