{"cve":"CVE-2026-4646","nvd":{"published":"2026-05-22T11:16:22.863","modified":"2026-07-23T16:10:00.137","status":"Analyzed","description":"Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to validate user-supplied input in API request handlers which allows an authenticated attacker to crash the plugin process via a crafted HTTP request to the PR details endpoint.. Mattermost Advisory ID: MMSA-2026-00638","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","score":4.3},"cwes":["CWE-1287"],"references":["https://mattermost.com/security-updates"],"products":["mattermost:mattermost_server"],"source":"nvd","synced_at":"2026-10-19T22:36:28.938604137+00:00"},"epss":{"cve":"CVE-2026-4646","score":0.0025,"percentile":0.16413,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-rmvv-8v8w-rf7x","url":"https://osv.dev/vulnerability/GHSA-rmvv-8v8w-rf7x","summary":"Mattermost doesn't validate user-supplied input in API request handlers","modified":"2026-07-07T16:11:11.164972428Z","packages":[{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":[">=11.6.0 <11.6.1"],"fixed":["11.6.1"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":[">=11.5.0 <11.5.4"],"fixed":["11.5.4"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":[">=11.4.0 <11.4.5"],"fixed":["11.4.5"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":[">=10.11.0 <10.11.15"],"fixed":["10.11.15"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost-plugin-github","purl":"pkg:golang/github.com/mattermost/mattermost-plugin-github","ranges":["<1.0.1-0.20260330164815-c2840e980b3c"],"fixed":["1.0.1-0.20260330164815-c2840e980b3c"]}]},{"id":"GO-2026-5833","url":"https://osv.dev/vulnerability/GO-2026-5833","summary":"Mattermost doesn't validate user-supplied input in API request handlers in github.com/mattermost/mattermost-plugin-github","modified":"2026-07-07T16:01:34.767462688Z","packages":[{"ecosystem":"Go","name":"github.com/mattermost/mattermost-plugin-github","purl":"pkg:golang/github.com/mattermost/mattermost-plugin-github","ranges":["<1.0.1-0.20260330164815-c2840e980b3c"],"fixed":["1.0.1-0.20260330164815-c2840e980b3c"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":[">=10.11.0+incompatible <10.11.15+incompatible",">=11.4.0+incompatible <11.4.5+incompatible",">=11.5.0+incompatible <11.5.4+incompatible",">=11.6.0+incompatible <11.6.1+incompatible"],"fixed":["10.11.15+incompatible","11.4.5+incompatible","11.5.4+incompatible","11.6.1+incompatible"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}