{"cve":"CVE-2026-42523","nvd":{"published":"2026-04-29T14:16:19.360","modified":"2026-10-26T20:10:00.160","status":"Analyzed","description":"Jenkins GitHub Plugin 1.46.0 and earlier improperly processes the current job URL as part of JavaScript implementing validation of the feature \"GitHub hook trigger for GITScm polling\", resulting in a stored cross-site scripting (XSS) vulnerability exploitable by non-anonymous attackers with Overall/Read permission.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","score":9.0},"cwes":["CWE-79"],"references":["https://www.jenkins.io/security/advisory/2026-04-29/#SECURITY-3704"],"products":["jenkins:github"],"source":"nvd","synced_at":"2026-10-26T20:34:58.897451322+00:00"},"epss":{"cve":"CVE-2026-42523","score":0.00281,"percentile":0.20387,"date":"2026-10-26"},"kev":null,"osv":[{"id":"GHSA-w22p-4x9f-486v","url":"https://osv.dev/vulnerability/GHSA-w22p-4x9f-486v","summary":"Jenkins GitHub Plugin has an XSS vulnerability","modified":"2026-08-14T20:00:07.189194775Z","packages":[{"ecosystem":"Maven","name":"com.coravy.hudson.plugins.github:github","purl":"pkg:maven/com.coravy.hudson.plugins.github/github","ranges":["<1.46.0.1"],"fixed":["1.46.0.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}