{"cve":"CVE-2026-41293","nvd":{"published":"2026-05-12T16:16:17.553","modified":"2026-10-26T18:10:00.173","status":"Analyzed","description":"Improper Input Validation vulnerability in Apache Tomcat.\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 10.0.0-M1 through 10.0.27.\nOlder, end of support versions may also be affected.\n\nUsers are recommended to upgrade to version [FIXED_VERSION], which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-20"],"references":["https://lists.apache.org/thread/qwg0q16z7xkb2qrr853wdll5531mvl1r","http://www.openwall.com/lists/oss-security/2026/05/12/13"],"products":["apache:tomcat"],"source":"nvd","synced_at":"2026-10-26T18:27:13.530666824+00:00"},"epss":{"cve":"CVE-2026-41293","score":0.01705,"percentile":0.77119,"date":"2026-10-26"},"kev":null,"osv":[{"id":"GHSA-r29c-68gh-xp6x","url":"https://osv.dev/vulnerability/GHSA-r29c-68gh-xp6x","summary":"Apache Tomcat - HTTP/2 request headers not validated","modified":"2026-09-10T03:50:55.679134930Z","packages":[{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=8.5.0 <9.0.118"],"fixed":["9.0.118"]},{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=10.1.0-M1 <10.1.55"],"fixed":["10.1.55"]},{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=11.0.0-M1 <11.0.22"],"fixed":["11.0.22"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat","purl":"pkg:maven/org.apache.tomcat/tomcat","ranges":[">=8.5.0 <9.0.118"],"fixed":["9.0.118"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat","purl":"pkg:maven/org.apache.tomcat/tomcat","ranges":[">=10.1.0-M1 <10.1.55"],"fixed":["10.1.55"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat","purl":"pkg:maven/org.apache.tomcat/tomcat","ranges":[">=11.0.0-M1 <11.0.22"],"fixed":["11.0.22"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=8.5.0 <9.0.118"],"fixed":["9.0.118"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=10.1.0-M1 <10.1.55"],"fixed":["10.1.55"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=11.0.0-M1 <11.0.22"],"fixed":["11.0.22"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}