{"cve":"CVE-2026-39304","nvd":{"published":"2026-04-10T11:16:23.143","modified":"2026-10-26T21:10:00.170","status":"Modified","description":"Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ.\n\nActiveMQ NIO SSL transports do not correctly handle TLSv1.3 handshake KeyUpdates triggered by clients. This makes it possible for a client to rapidly trigger updates which causes the broker to exhaust all its memory in the SSL engine leading to DoS.\n\nNote: TLS versions before TLSv1.3 (such as TLSv1.2) are broken but are not vulnerable to OOM. Previous TLS versions require a full handshake renegotiation which causes a connection to hang but not OOM. This is fixed as well.\nThis issue affects Apache ActiveMQ Client: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.4.\n\nUsers are recommended to upgrade to version 6.2.4 or 5.19.5, which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-400","CWE-770"],"references":["https://activemq.apache.org/security-advisories.data/CVE-2026-39304-announcement.txt","http://www.openwall.com/lists/oss-security/2026/04/09/17","https://access.redhat.com/security/cve/CVE-2026-39304","https://bugzilla.redhat.com/show_bug.cgi?id=2457275","https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-39304.json"],"products":["apache:activemq","apache:activemq_broker"],"source":"nvd","synced_at":"2026-10-26T21:38:48.864438205+00:00"},"epss":{"cve":"CVE-2026-39304","score":0.00896,"percentile":0.5929,"date":"2026-10-26"},"kev":null,"osv":[{"id":"GHSA-5568-6qcg-g7fx","url":"https://osv.dev/vulnerability/GHSA-5568-6qcg-g7fx","summary":" Apache ActiveMQ: Denial of Service via Out of Memory vulnerability","modified":"2026-09-10T03:50:43.215311840Z","packages":[{"ecosystem":"Maven","name":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","ranges":["<5.19.4"],"fixed":["5.19.4"]},{"ecosystem":"Maven","name":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","ranges":[">=6.0.0 <6.2.4"],"fixed":["6.2.4"]},{"ecosystem":"Maven","name":"org.apache.activemq:activemq-broker","purl":"pkg:maven/org.apache.activemq/activemq-broker","ranges":["<5.19.4"],"fixed":["5.19.4"]},{"ecosystem":"Maven","name":"org.apache.activemq:activemq-broker","purl":"pkg:maven/org.apache.activemq/activemq-broker","ranges":[">=6.0.0 <6.2.4"],"fixed":["6.2.4"]},{"ecosystem":"Maven","name":"org.apache.activemq:activemq-all","purl":"pkg:maven/org.apache.activemq/activemq-all","ranges":["<5.19.4"],"fixed":["5.19.4"]},{"ecosystem":"Maven","name":"org.apache.activemq:activemq-all","purl":"pkg:maven/org.apache.activemq/activemq-all","ranges":[">=6.0.0 <6.2.4"],"fixed":["6.2.4"]},{"ecosystem":"Maven","name":"org.apache.activemq:apache-activemq","purl":"pkg:maven/org.apache.activemq/apache-activemq","ranges":["<5.19.4"],"fixed":["5.19.4"]},{"ecosystem":"Maven","name":"org.apache.activemq:apache-activemq","purl":"pkg:maven/org.apache.activemq/apache-activemq","ranges":[">=6.0.0 <6.2.4"],"fixed":["6.2.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}