{"cve":"CVE-2026-33532","nvd":{"published":"2026-03-26T20:16:15.543","modified":"2026-06-17T10:37:39.880","status":"Analyzed","description":"`yaml` is a YAML parser and serialiser for JavaScript. Parsing a YAML document with a version of `yaml` on the 1.x branch prior to 1.10.3 or on the 2.x branch prior to 2.8.3 may throw a RangeError due to a stack overflow. The node resolution/composition phase uses recursive function calls without a depth bound. An attacker who can supply YAML for parsing can trigger a `RangeError: Maximum call stack size exceeded` with a small payload (~2–10 KB). The `RangeError` is not a `YAMLParseError`, so applications that only catch YAML-specific errors will encounter an unexpected exception type. Depending on the host application's exception handling, this can fail requests or terminate the Node.js process. Flow sequences allow deep nesting with minimal bytes (2 bytes per level: one `[` and one `]`). On the default Node.js stack, approximately 1,000–5,000 levels of nesting (2–10 KB input) exhaust the call stack. The exact threshold is environment-dependent (Node.js version, stack size, call stack depth at invocation). Note: the library's `Parser` (CST phase) uses a stack-based iterative approach and is not affected. Only the compose/resolve phase uses actual call-stack recursion. All three public parsing APIs are affected: `YAML.parse()`, `YAML.parseDocument()`, and `YAML.parseAllDocuments()`. Versions 1.10.3 and 2.8.3 contain a patch.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","score":4.3},"cwes":["CWE-674"],"references":["https://github.com/eemeli/yaml/commit/1e84ebbea7ec35011a4c61bbb820a529ee4f359b","https://github.com/eemeli/yaml/releases/tag/v1.10.3","https://github.com/eemeli/yaml/releases/tag/v2.8.3","https://github.com/eemeli/yaml/security/advisories/GHSA-48c2-rrv3-qjmp"],"products":["eemeli:yaml"],"source":"nvd","synced_at":"2026-10-19T22:28:18.033120106+00:00"},"epss":{"cve":"CVE-2026-33532","score":0.00488,"percentile":0.42049,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-48c2-rrv3-qjmp","url":"https://osv.dev/vulnerability/GHSA-48c2-rrv3-qjmp","summary":"yaml is vulnerable to Stack Overflow via deeply nested YAML collections","modified":"2026-09-10T03:50:37.151581408Z","packages":[{"ecosystem":"npm","name":"yaml","purl":"pkg:npm/yaml","ranges":[">=2.0.0 <2.8.3"],"fixed":["2.8.3"]},{"ecosystem":"npm","name":"yaml","purl":"pkg:npm/yaml","ranges":[">=1.0.0 <1.10.3"],"fixed":["1.10.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}