{"cve":"CVE-2026-32944","nvd":{"published":"2026-03-18T22:16:25.970","modified":"2026-06-17T10:36:36.617","status":"Analyzed","description":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.21 and 8.6.45, an unauthenticated attacker can crash the Parse Server process by sending a single request with deeply nested query condition operators. This terminates the server and denies service to all connected clients. Starting in version 9.6.0-alpha.21 and 8.6.45, a depth limit for query condition operator nesting has been added via the `requestComplexity.queryDepth` server option. The option is disabled by default to avoid a breaking change. To mitigate, upgrade and set the option to a value appropriate for your app. No known workarounds are available.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","score":8.7},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-674"],"references":["https://github.com/parse-community/parse-server/pull/10202","https://github.com/parse-community/parse-server/pull/10203","https://github.com/parse-community/parse-server/security/advisories/GHSA-9xp9-j92r-p88v"],"products":["parseplatform:parse-server"],"source":"nvd","synced_at":"2026-10-19T22:26:19.218427112+00:00"},"epss":{"cve":"CVE-2026-32944","score":0.00502,"percentile":0.4296,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-9xp9-j92r-p88v","url":"https://osv.dev/vulnerability/GHSA-9xp9-j92r-p88v","summary":"Parse Server crash via deeply nested query condition operators","modified":"2026-03-20T12:26:14.750267Z","packages":[{"ecosystem":"npm","name":"parse-server","purl":"pkg:npm/parse-server","ranges":[">=9.0.0 <9.6.0-alpha.21"],"fixed":["9.6.0-alpha.21"]},{"ecosystem":"npm","name":"parse-server","purl":"pkg:npm/parse-server","ranges":["<8.6.45"],"fixed":["8.6.45"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}