{"cve":"CVE-2026-30922","nvd":{"published":"2026-03-18T04:17:18.397","modified":"2026-09-10T13:18:04.640","status":"Modified","description":"pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.3, the `pyasn1` library is vulnerable to a Denial of Service (DoS) attack caused by uncontrolled recursion when decoding ASN.1 data with deeply nested structures. An attacker can supply a crafted payload containing thousands of nested `SEQUENCE` (`0x30`) or `SET` (`0x31`) tags with \"Indefinite Length\" (`0x80`) markers. This forces the decoder to recursively call itself until the Python interpreter crashes with a `RecursionError` or consumes all available memory (OOM), crashing the host application. This is a distinct vulnerability from CVE-2026-23490 (which addressed integer overflows in OID decoding). The fix for CVE-2026-23490 (`MAX_OID_ARC_CONTINUATION_OCTETS`) does not mitigate this recursion issue. Version 0.6.3 fixes this specific issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-674","CWE-835"],"references":["https://github.com/pyasn1/pyasn1/commit/25ad481c19fdb006e20485ef3fc2e5b3eff30ef0","https://github.com/pyasn1/pyasn1/security/advisories/GHSA-jr27-m4p2-rc6r","http://www.openwall.com/lists/oss-security/2026/03/20/4","https://lists.debian.org/debian-lts-announce/2026/05/msg00001.html","https://access.redhat.com/errata/RHSA-2026:10184"],"products":["pyasn1:pyasn1"],"source":"nvd","synced_at":"2026-10-19T22:26:19.218427112+00:00"},"epss":{"cve":"CVE-2026-30922","score":0.00817,"percentile":0.57138,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-jr27-m4p2-rc6r","url":"https://osv.dev/vulnerability/GHSA-jr27-m4p2-rc6r","summary":"Denial of Service in pyasn1 via Unbounded Recursion","modified":"2026-09-09T15:45:11.173742426Z","packages":[{"ecosystem":"PyPI","name":"pyasn1","purl":"pkg:pypi/pyasn1","ranges":["<0.6.3"],"fixed":["0.6.3"]}]},{"id":"PYSEC-2026-2263","url":"https://osv.dev/vulnerability/PYSEC-2026-2263","summary":"","modified":"2026-07-13T07:15:40.277367904Z","packages":[{"ecosystem":"PyPI","name":"pyasn1","purl":"pkg:pypi/pyasn1","ranges":["<0.6.3"],"fixed":["0.6.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}