{"cve":"CVE-2026-2839","nvd":{"published":"2026-10-28T07:16:48.367","modified":"2026-10-28T07:16:48.367","status":"Received","description":"The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions in all versions up to, and including, 0.9.2.7. This is due to multiple AJAX handlers registered for unauthenticated users (`wp_ajax_nopriv_*`) that fail to implement proper `current_user_can()` authorization checks. While these handlers use ACF's `acf_verify_ajax()` function to validate cryptographic nonces, the `acf_nonce` values are generated for guest users and publicly exposed in the page source of any frontend page utilizing an ACF form. This makes it possible for unauthenticated attackers to extract the guest nonce and bypass WordPress visibility permissions, leading to the unauthorized disclosure of post titles and internal Flexible Content layout structures. The vulnerability was partially patched in version 0.9.2.4.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","score":5.3},"cwes":["CWE-862"],"references":["https://plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/fields/field-advanced-link.php#L25","https://plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/fields/field-advanced-link.php#L603","https://plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/fields/field-flexible-content-async.php#L151","https://plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/fields/field-flexible-content-async.php#L24","https://plugins.trac.wordpress.org/changeset/3516027/"],"products":[],"source":"nvd","synced_at":"2026-10-28T07:37:43.411221249+00:00"},"epss":null,"kev":null,"osv":[],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}