{"cve":"CVE-2026-27809","nvd":{"published":"2026-02-26T00:16:26.233","modified":"2026-06-17T10:27:43.263","status":"Analyzed","description":"psd-tools is a Python package for working with Adobe Photoshop PSD files. Prior to version 1.12.2, when a PSD file contains malformed RLE-compressed image data (e.g. a literal run that extends past the expected row size), decode_rle() raises ValueError which propagated all the way to the user, crashing psd.composite() and psd-tools export. decompress() already had a fallback that replaces failed channels with black pixels when result is None, but it never triggered because the ValueError from decode_rle() was not caught. The fix in version 1.12.2 wraps the decode_rle() call in a try/except so the existing fallback handles the error gracefully.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","score":6.8},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H","score":9.1},"cwes":["CWE-190","CWE-409","CWE-617","CWE-704","CWE-755","CWE-789"],"references":["https://github.com/psd-tools/psd-tools/commit/6c0a78f195b5942757886a1863793fd5946c1fb1","https://github.com/psd-tools/psd-tools/releases/tag/v1.12.2","https://github.com/psd-tools/psd-tools/security/advisories/GHSA-24p2-j2jr-386w"],"products":["psd-tools_project:psd-tools"],"source":"nvd","synced_at":"2026-10-19T22:24:17.937441719+00:00"},"epss":{"cve":"CVE-2026-27809","score":0.0048,"percentile":0.41414,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-24p2-j2jr-386w","url":"https://osv.dev/vulnerability/GHSA-24p2-j2jr-386w","summary":"psd-tools: Compression module has unguarded zlib decompression, missing dimension validation, and hardening gaps","modified":"2026-07-13T07:26:55.444033267Z","packages":[{"ecosystem":"PyPI","name":"psd-tools","purl":"pkg:pypi/psd-tools","ranges":["<1.12.2"],"fixed":["1.12.2"]}]},{"id":"PYSEC-2026-2262","url":"https://osv.dev/vulnerability/PYSEC-2026-2262","summary":"","modified":"2026-07-13T07:15:40.078708735Z","packages":[{"ecosystem":"PyPI","name":"psd-tools","purl":"pkg:pypi/psd-tools","ranges":["<1.12.2"],"fixed":["1.12.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}