{"cve":"CVE-2026-26191","nvd":{"published":"2026-05-14T20:17:02.173","modified":"2026-10-26T14:10:00.130","status":"Analyzed","description":"Fleet is open source device management software. Prior to version 4.81.0, a vulnerability in Fleet's software installer pipeline could allow a crafted software package to execute arbitrary commands as root (macOS/Linux) or SYSTEM (Windows) on managed endpoints when an uninstall is triggered. When a software package (.pkg, .deb, .rpm, .exe, or .msi) is uploaded to Fleet, metadata is extracted from the package binary and used to generate uninstall scripts. In affected versions, this metadata is not properly sanitized before being included in the generated scripts. A specially crafted package containing malicious values in its metadata fields could result in unintended command execution when the uninstall script runs on managed endpoints. Version 4.81.0 contains a patch. If an immediate upgrade is not possible, administrators should avoid uploading software packages obtained from untrusted or unverified sources. Additionally, administrators can manually inspect and edit auto-generated uninstall scripts before deployment.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","score":6.0},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-78"],"references":["https://github.com/fleetdm/fleet/releases/tag/fleet-v4.81.1","https://github.com/fleetdm/fleet/security/advisories/GHSA-9vcr-g537-3w5v"],"products":["fleetdm:fleet"],"source":"nvd","synced_at":"2026-10-26T14:27:29.784594657+00:00"},"epss":{"cve":"CVE-2026-26191","score":0.00773,"percentile":0.55425,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-9vcr-g537-3w5v","url":"https://osv.dev/vulnerability/GHSA-9vcr-g537-3w5v","summary":"Fleet vulnerable to OS command injection in software packages","modified":"2026-06-25T19:56:32.609469346Z","packages":[{"ecosystem":"Go","name":"github.com/fleetdm/fleet/v4","purl":"pkg:golang/github.com/fleetdm/fleet/v4","ranges":["<4.81.1"],"fixed":["4.81.1"]}]},{"id":"GO-2026-5301","url":"https://osv.dev/vulnerability/GO-2026-5301","summary":"Fleet vulnerable to OS command injection in software packages in github.com/fleetdm/fleet","modified":"2026-06-25T19:45:27.554519579Z","packages":[{"ecosystem":"Go","name":"github.com/fleetdm/fleet/v4","purl":"pkg:golang/github.com/fleetdm/fleet/v4","ranges":["<4.81.1"],"fixed":["4.81.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}