{"cve":"CVE-2026-24734","nvd":{"published":"2026-02-17T19:21:56.953","modified":"2026-07-15T14:17:21.530","status":"Modified","description":"Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat.\n\nWhen using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed.\n\nThis issue affects Apache Tomcat Native:  from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114.\n\n\nThe following versions were EOL at the time the CVE was created but are \nknown to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected.\n\nApache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue.\n\nApache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","score":7.5},"cwes":["CWE-20","CWE-295"],"references":["https://lists.apache.org/thread/292dlmx3fz1888v6v16221kpozq56gml","https://access.redhat.com/errata/RHSA-2026:19054","https://access.redhat.com/errata/RHSA-2026:26323","https://access.redhat.com/errata/RHSA-2026:36790","https://access.redhat.com/errata/RHSA-2026:5611"],"products":["apache:tomcat","apache:tomcat_native"],"source":"nvd","synced_at":"2026-10-19T22:23:35.260773158+00:00"},"epss":{"cve":"CVE-2026-24734","score":0.00575,"percentile":0.47473,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-mgp5-rv84-w37q","url":"https://osv.dev/vulnerability/GHSA-mgp5-rv84-w37q","summary":"Apache Tomcat has an Improper Input Validation vulnerability","modified":"2026-09-10T03:50:35.574464523Z","packages":[{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=11.0.0-M1 <11.0.18"],"fixed":["11.0.18"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=10.1.0-M7 <10.1.52"],"fixed":["10.1.52"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=9.0.83 <9.0.115"],"fixed":["9.0.115"]},{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=11.0.0-M1 <11.0.18"],"fixed":["11.0.18"]},{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=10.1.0-M7 <10.1.52"],"fixed":["10.1.52"]},{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=9.0.83 <9.0.115"],"fixed":["9.0.115"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}