{"cve":"CVE-2026-23983","nvd":{"published":"2026-02-24T14:16:23.143","modified":"2026-06-17T10:22:23.793","status":"Analyzed","description":"A Sensitive Data Exposure vulnerability exists in Apache Superset allowing authenticated users to retrieve sensitive user information. The Tag endpoint (disabled by default) allows users to retrieve a list of objects associated with a specific tag.\nWhen these associated objects include Users, the API response improperly serializes and returns sensitive fields, including password hashes (pbkdf2), email addresses, and login statistics. This vulnerability allows authenticated users with low privileges (e.g., Gamma role) to view sensitive authentication data \n\nThis issue affects Apache Superset: before 6.0.0.\n\nUsers are recommended to upgrade to version 6.0.0, which fixes the issue or make sure TAGGING_SYSTEM is False (Apache Superset current default)","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","score":2.3},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","score":6.5},"cwes":["CWE-200"],"references":["https://lists.apache.org/thread/62mgbc5hc8026skp69kb6vqozj3pr5ww","http://www.openwall.com/lists/oss-security/2026/02/24/7"],"products":["apache:superset"],"source":"nvd","synced_at":"2026-10-19T22:24:17.937441719+00:00"},"epss":{"cve":"CVE-2026-23983","score":0.00471,"percentile":0.40793,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-h294-8fxm-m2pj","url":"https://osv.dev/vulnerability/GHSA-h294-8fxm-m2pj","summary":"Apache Superset allows authenticated users to view sensitive data without explicit permissions","modified":"2026-07-13T16:43:43.919783236Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<6.0.0"],"fixed":["6.0.0"]}]},{"id":"PYSEC-2026-2375","url":"https://osv.dev/vulnerability/PYSEC-2026-2375","summary":"Apache Superset allows authenticated users to view sensitive data without explicit permissions","modified":"2026-07-13T16:43:43.919783236Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<6.0.0"],"fixed":["6.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}