{"cve":"CVE-2026-23980","nvd":{"published":"2026-02-24T14:16:22.807","modified":"2026-06-17T10:22:23.543","status":"Analyzed","description":"Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection') vulnerability in Apache Superset allows an authenticated user with read access to conduct error-based SQL injection via the sqlExpression or where parameters.\n\nThis issue affects Apache Superset: before 6.0.0.\n\nUsers are recommended to upgrade to version 6.0.0, which fixes the issue.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","score":5.3},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","score":6.5},"cwes":["CWE-89"],"references":["https://lists.apache.org/thread/h4l02zw1pr2vywv0dc5zjn3grdcdhwf4","http://www.openwall.com/lists/oss-security/2026/02/24/5"],"products":["apache:superset"],"source":"nvd","synced_at":"2026-10-19T22:24:17.937441719+00:00"},"epss":{"cve":"CVE-2026-23980","score":0.0071,"percentile":0.53551,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-gvxg-9hqx-f4rg","url":"https://osv.dev/vulnerability/GHSA-gvxg-9hqx-f4rg","summary":"Apache Superset allows privileged users to conduct error-based SQL Injection","modified":"2026-07-13T16:43:07.748028623Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<6.0.0"],"fixed":["6.0.0"]}]},{"id":"PYSEC-2026-2374","url":"https://osv.dev/vulnerability/PYSEC-2026-2374","summary":"Apache Superset allows privileged users to conduct error-based SQL Injection","modified":"2026-07-13T16:43:07.748028623Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<6.0.0"],"fixed":["6.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}