{"cve":"CVE-2026-2229","nvd":{"published":"2026-03-12T21:16:25.573","modified":"2026-09-04T13:18:41.890","status":"Modified","description":"ImpactThe undici WebSocket client is vulnerable to a denial-of-service attack due to improper validation of the server_max_window_bits parameter in the permessage-deflate extension. When a WebSocket client connects to a server, it automatically advertises support for permessage-deflate compression. A malicious server can respond with an out-of-range server_max_window_bits value (outside zlib's valid range of 8-15). When the server subsequently sends a compressed frame, the client attempts to create a zlib InflateRaw instance with the invalid windowBits value, causing a synchronous RangeError exception that is not caught, resulting in immediate process termination.\n\nThe vulnerability exists because:\n\n  *  The isValidClientWindowBits() function only validates that the value contains ASCII digits, not that it falls within the valid range 8-15\n  *  The createInflateRaw() call is not wrapped in a try-catch block\n  *  The resulting exception propagates up through the call stack and crashes the Node.js process","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-248","CWE-1284"],"references":["https://cna.openjsf.org/security-advisories.html","https://datatracker.ietf.org/doc/html/rfc7692","https://github.com/nodejs/undici/security/advisories/GHSA-v9p9-hfj2-hcw8","https://hackerone.com/reports/3487486","https://nodejs.org/api/zlib.html#class-zlibinflateraw"],"products":["nodejs:undici"],"source":"nvd","synced_at":"2026-10-19T22:25:53.701907451+00:00"},"epss":{"cve":"CVE-2026-2229","score":0.00909,"percentile":0.59972,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-v9p9-hfj2-hcw8","url":"https://osv.dev/vulnerability/GHSA-v9p9-hfj2-hcw8","summary":"Undici has Unhandled Exception in WebSocket Client Due to Invalid server_max_window_bits Validation","modified":"2026-09-10T03:50:41.228925580Z","packages":[{"ecosystem":"npm","name":"undici","purl":"pkg:npm/undici","ranges":["<6.24.0"],"fixed":["6.24.0"]},{"ecosystem":"npm","name":"undici","purl":"pkg:npm/undici","ranges":[">=7.0.0 <7.24.0"],"fixed":["7.24.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}