{"cve":"CVE-2026-15830","nvd":{"published":"2026-08-04T17:16:46.593","modified":"2026-10-24T16:10:00.153","status":"Modified","description":"An issue was discovered in Django 6.0 before 6.0.9 and 5.2 before 5.2.18.\nGeoDjango's `django.contrib.gis.geos.GEOSGeometry` is subject to a potential denial-of-service when parsing deeply nested `GEOMETRYCOLLECTION` objects supplied as well-known text (WKT), well-known binary (WKB), or hex-encoded WKB, which triggers unbounded recursion and a segmentation fault in the underlying GEOS library. Spatial field lookups and the `django.contrib.gis.forms.GeometryField` form field are also affected.\nEarlier, unsupported Django series (such as 5.1.x, 5.0.x, and 4.2.x) were not evaluated and may also be affected.\nDjango would like to thank Andrew MacPherson and kimchunbok_ for reporting this issue.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","score":6.9},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","score":5.3},"cwes":["CWE-674"],"references":["https://docs.djangoproject.com/en/dev/releases/security/","https://github.com/django/django/commit/1eafa1a80f1363283f89208ba4499ed54e35f085","https://github.com/django/django/commit/4353dfb56f8ba3a6fccc4bdd7f2ef2fbee3aa638","https://github.com/django/django/commit/62ef9d40cf4ea75f16518436b44b8ab2515340df","https://github.com/django/django/commit/6af5da31775417c610dbf9c3f1b5b8333d42daf6"],"products":["djangoproject:django"],"source":"nvd","synced_at":"2026-10-24T16:53:34.184483516+00:00"},"epss":{"cve":"CVE-2026-15830","score":0.01113,"percentile":0.65764,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-q238-5cxm-5c9h","url":"https://osv.dev/vulnerability/GHSA-q238-5cxm-5c9h","summary":"Django GeoDjango vulnerable to denial of service through deeply nested geometry collections","modified":"2026-10-12T14:45:06.559694358Z","packages":[{"ecosystem":"PyPI","name":"django","purl":"pkg:pypi/django","ranges":["<5.2.17"],"fixed":["5.2.17"]},{"ecosystem":"PyPI","name":"django","purl":"pkg:pypi/django","ranges":[">=6.0a1 <6.0.8"],"fixed":["6.0.8"]},{"ecosystem":"PyPI","name":"django","purl":"pkg:pypi/django","ranges":[">=6.1a1 <6.1.1"],"fixed":["6.1.1"]}]},{"id":"PYSEC-2026-3717","url":"https://osv.dev/vulnerability/PYSEC-2026-3717","summary":"","modified":"2026-10-01T17:15:02.507678321Z","packages":[{"ecosystem":"PyPI","name":"django","purl":"pkg:pypi/django","ranges":["<5.2.17",">=6.0 <6.0.8"],"fixed":["5.2.17","6.0.8"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}