{"cve":"CVE-2026-114111","nvd":{"published":"2026-10-21T01:17:37.250","modified":"2026-10-22T17:39:56.760","status":"Awaiting Analysis","description":"sharp before 0.35.5 bundles a librsvg dependency affected by a memory-related vulnerability (CVE-2026-96889) that, under certain runtime-specific conditions, can lead to code execution on glibc-based Linux. An attacker can supply a crafted SVG image that, when decoded by sharp through librsvg, may result in arbitrary code execution.","cvss_v4":{"vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","score":8.9},"cvss_v3":null,"cwes":["CWE-416"],"references":["https://github.com/lovell/sharp/security/advisories/GHSA-wq5f-xc86-pv6w","https://www.vulncheck.com/advisories/sharp-before-0.35.5-rce-via-librsvg-dependency-memory-vulnerability"],"products":[],"source":"nvd","synced_at":"2026-10-23T16:39:26.291718493+00:00"},"epss":{"cve":"CVE-2026-114111","score":0.00129,"percentile":0.02491,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-wq5f-xc86-pv6w","url":"https://osv.dev/vulnerability/GHSA-wq5f-xc86-pv6w","summary":"sharp : Vulnerability in librsvg dependency CVE-2026-96889","modified":"2026-10-21T10:57:27.441638733Z","packages":[{"ecosystem":"npm","name":"sharp","purl":"pkg:npm/sharp","ranges":["<0.35.5"],"fixed":["0.35.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}