{"cve":"CVE-2026-11332","nvd":{"published":"2026-06-05T09:16:26.070","modified":"2026-10-21T19:17:01.183","status":"Awaiting Analysis","description":"A flaw was found in ansible-core. The ansible-galaxy role install command processes dependency specifications from a role's meta/requirements.yml file. Due to improper neutralization of argument delimiters, a malicious role author can inject arbitrary git configuration flags through the src field. This allows arbitrary code execution on the machine of a user who installs the role via ansible-galaxy role install.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":7.8},"cwes":["CWE-88"],"references":["https://access.redhat.com/errata/RHSA-2026:42078","https://access.redhat.com/errata/RHSA-2026:42079","https://access.redhat.com/errata/RHSA-2026:42080","https://access.redhat.com/errata/RHSA-2026:46836","https://access.redhat.com/errata/RHSA-2026:50340"],"products":[],"source":"nvd","synced_at":"2026-10-22T16:41:11.231219466+00:00"},"epss":{"cve":"CVE-2026-11332","score":0.00222,"percentile":0.12628,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-w8p5-mx5w-cpqj","url":"https://osv.dev/vulnerability/GHSA-w8p5-mx5w-cpqj","summary":"ansible-core: Argument injection in ansible-galaxy role install leads to arbitrary code execution","modified":"2026-07-23T15:11:38.566563365Z","packages":[{"ecosystem":"PyPI","name":"ansible-core","purl":"pkg:pypi/ansible-core","ranges":["<2.16.19rc1"],"fixed":["2.16.19rc1"]},{"ecosystem":"PyPI","name":"ansible-core","purl":"pkg:pypi/ansible-core","ranges":[">=2.17.0b1 <2.18.18rc1"],"fixed":["2.18.18rc1"]},{"ecosystem":"PyPI","name":"ansible-core","purl":"pkg:pypi/ansible-core","ranges":[">=2.19.0b1 <2.19.11rc1"],"fixed":["2.19.11rc1"]},{"ecosystem":"PyPI","name":"ansible-core","purl":"pkg:pypi/ansible-core","ranges":[">=2.20.0b1 <2.20.7rc1"],"fixed":["2.20.7rc1"]},{"ecosystem":"PyPI","name":"ansible-core","purl":"pkg:pypi/ansible-core","ranges":[">=2.21.0b1 <2.21.1rc1"],"fixed":["2.21.1rc1"]}]},{"id":"PYSEC-2026-3458","url":"https://osv.dev/vulnerability/PYSEC-2026-3458","summary":"ansible-core: Argument injection in ansible-galaxy role install leads to arbitrary code execution","modified":"2026-07-23T15:00:10.910213748Z","packages":[{"ecosystem":"PyPI","name":"ansible-core","purl":"pkg:pypi/ansible-core","ranges":["<2.16.19rc1",">=2.17.0b1 <2.18.18rc1",">=2.19.0b1 <2.19.11rc1",">=2.20.0b1 <2.20.7rc1",">=2.21.0b1 <2.21.1rc1"],"fixed":["2.16.19rc1","2.18.18rc1","2.19.11rc1","2.20.7rc1","2.21.1rc1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}