{"cve":"CVE-2026-111497","nvd":{"published":"2026-10-22T14:17:37.190","modified":"2026-10-26T05:17:53.007","status":"Awaiting Analysis","description":"A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.\n\n\n\n\n\nUsers need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","score":9.2},"cvss_v3":null,"cwes":["CWE-252","CWE-787"],"references":["https://nodejs.org/en/blog/vulnerability/october-2026-security-releases#nodejs-brotli-decoder-out-of-bounds-write-permits-remote-code-execution-cve-2026-111497---high","http://www.openwall.com/lists/oss-security/2026/10/23/25","http://www.openwall.com/lists/oss-security/2026/10/24/6","http://www.openwall.com/lists/oss-security/2026/10/26/12","http://www.openwall.com/lists/oss-security/2026/10/26/13"],"products":[],"source":"nvd","synced_at":"2026-10-26T06:30:04.204310498+00:00"},"epss":{"cve":"CVE-2026-111497","score":0.32782,"percentile":0.98336,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-9v8h-qqgm-4m35","url":"https://osv.dev/vulnerability/GHSA-9v8h-qqgm-4m35","summary":"Brotli: Out-of-bounds write in the Brotli decoder (\"Node2Shell\") also affects the PyPI Brotli package","modified":"2026-10-24T10:55:42.890666980Z","packages":[{"ecosystem":"PyPI","name":"brotli","purl":"pkg:pypi/brotli","ranges":[">=1.0.3 <1.2.1"],"fixed":["1.2.1"]},{"ecosystem":"PyPI","name":"brotlicffi","purl":"pkg:pypi/brotlicffi","ranges":[">=1.0.3 <1.2.1.0"],"fixed":["1.2.1.0"]}]},{"id":"PYSEC-2026-4322","url":"https://osv.dev/vulnerability/PYSEC-2026-4322","summary":"Out-of-bounds write in the Brotli decoder (\"Node2Shell\") also affects the PyPI Brotli package","modified":"2026-10-24T10:55:42.890666980Z","packages":[{"ecosystem":"PyPI","name":"brotli","purl":"pkg:pypi/brotli","ranges":["<1.2.1"],"fixed":["1.2.1"]}]},{"id":"PYSEC-2026-4323","url":"https://osv.dev/vulnerability/PYSEC-2026-4323","summary":"Out-of-bounds write in the brotlicffi decoder (\"Node2Shell\") also affects the PyPI Brotli package","modified":"2026-10-24T10:55:42.890666980Z","packages":[{"ecosystem":"PyPI","name":"brotlicffi","purl":"pkg:pypi/brotlicffi","ranges":["<1.2.1.0"],"fixed":["1.2.1.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}