{"cve":"CVE-2026-109924","nvd":{"published":"2026-10-15T19:17:22.180","modified":"2026-10-19T20:45:00.433","status":"Analyzed","description":"undici is an HTTP client library for Node.js. In versions 6.5.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its EventSource client can be driven to exhaust process memory by a malicious or compromised Server-Sent Events peer. By sending millions of tiny completed data fields with no blank event separator, or a single unfinished line split across many chunks, the parser retains a growing amount of per-field and per-chunk state that the byte-based maxEventSize and maxResponseSize limits do not bound, and because maxResponseSize is enforced on the compressed body before decompression, a small compressed response can expand into enough retained memory to terminate the process. An application only needs to maintain an EventSource connection to an untrusted peer, which controls only the response, and availability is the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which bound the retained parser state independently of the byte limits, and users should upgrade to one of those versions or later. There is no workaround.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-770"],"references":["https://cna.openjsf.org/security-advisories.html","https://github.com/nodejs/undici/security/advisories/GHSA-4qv8-2p9j-2685"],"products":["nodejs:undici"],"source":"nvd","synced_at":"2026-10-21T03:56:58.798400159+00:00"},"epss":{"cve":"CVE-2026-109924","score":0.00321,"percentile":0.24857,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-4qv8-2p9j-2685","url":"https://osv.dev/vulnerability/GHSA-4qv8-2p9j-2685","summary":"undici vulnerable to Denial of Service via unbounded memory in the EventSource parser","modified":"2026-10-23T22:30:04.104974737Z","packages":[{"ecosystem":"npm","name":"undici","purl":"pkg:npm/undici","ranges":[">=6.5.0 <6.29.1"],"fixed":["6.29.1"]},{"ecosystem":"npm","name":"undici","purl":"pkg:npm/undici","ranges":[">=7.0.0 <7.30.1"],"fixed":["7.30.1"]},{"ecosystem":"npm","name":"undici","purl":"pkg:npm/undici","ranges":[">=8.0.0 <8.12.2"],"fixed":["8.12.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}