{"cve":"CVE-2026-109869","nvd":{"published":"2026-10-15T19:17:21.770","modified":"2026-10-19T20:45:20.340","status":"Analyzed","description":"undici is an HTTP client library for Node.js. In versions 6.23.0 through 6.29.0, 7.18.0 through 7.30.0, and 8.0.0 through 8.12.1, its fetch() implementation crashes the Node.js process when a malicious server returns a response with more than five content codings and closes the connection before sending the body. undici rejects such responses because of a content-encoding limit, but it created the internal response stream before that check and returned without attaching an error listener or aborting the request, so the early close surfaces a content-length mismatch on the orphaned stream, which Node.js treats as an unhandled error and terminates the process. A remote, unauthenticated server can trigger this with a single response, even when the application correctly catches the fetch() rejection, resulting in a denial of service. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. There is no workaround.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-248","CWE-459"],"references":["https://cna.openjsf.org/security-advisories.html","https://github.com/nodejs/undici/security/advisories/GHSA-xjj6-f33q-929c"],"products":["nodejs:undici"],"source":"nvd","synced_at":"2026-10-21T03:56:58.798400159+00:00"},"epss":{"cve":"CVE-2026-109869","score":0.00344,"percentile":0.27642,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-xjj6-f33q-929c","url":"https://osv.dev/vulnerability/GHSA-xjj6-f33q-929c","summary":"undici vulnerable to Denial of Service via unhandled error on excessive content-encodings","modified":"2026-10-23T22:30:05.007687918Z","packages":[{"ecosystem":"npm","name":"undici","purl":"pkg:npm/undici","ranges":[">=6.23.0 <6.29.1"],"fixed":["6.29.1"]},{"ecosystem":"npm","name":"undici","purl":"pkg:npm/undici","ranges":[">=7.18.0 <7.30.1"],"fixed":["7.30.1"]},{"ecosystem":"npm","name":"undici","purl":"pkg:npm/undici","ranges":[">=8.0.0 <8.12.2"],"fixed":["8.12.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}