{"cve":"CVE-2026-106456","nvd":{"published":"2026-10-06T21:17:15.903","modified":"2026-10-07T19:17:32.633","status":"Undergoing Analysis","description":"Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N","score":4.8},"cwes":["CWE-863"],"references":["https://github.com/backstage/backstage/commit/9df92923ac32558bb80edeceafd8de780c44e218","https://github.com/backstage/backstage/releases/tag/v1.55.0","https://github.com/backstage/backstage/security/advisories/GHSA-472h-9c5j-prrr"],"products":[],"source":"nvd","synced_at":"2026-10-19T22:58:01.639778232+00:00"},"epss":{"cve":"CVE-2026-106456","score":0.00236,"percentile":0.14471,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-472h-9c5j-prrr","url":"https://osv.dev/vulnerability/GHSA-472h-9c5j-prrr","summary":"Backstage: Inconsistent credential enforcement for overlapping proxy routes","modified":"2026-10-07T20:30:07.225533458Z","packages":[{"ecosystem":"npm","name":"@backstage/plugin-proxy-backend","purl":"pkg:npm/%40backstage/plugin-proxy-backend","ranges":[">=0.5.0 <0.6.18"],"fixed":["0.6.18"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}