{"cve":"CVE-2026-105756","nvd":{"published":"2026-10-05T23:17:02.317","modified":"2026-10-08T01:28:23.010","status":"Analyzed","description":"vLLM is an inference and serving engine for large language models. Prior to 0.30.0, OpenAI-compatible request models accept a non-empty cache_salt value without enforcing the character and length restrictions required by the IPCCacheServerKey consumer in LMCache-MP. On deployments using the LMCache-MP connector, a salt that contains a forbidden character or exceeds the permitted length can raise an uncaught ValueError during scheduler cache lookup, causing EngineCore to terminate and denying service to all concurrent users. This issue is fixed in version 0.30.0.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","score":6.5},"cwes":["CWE-20","CWE-248"],"references":["https://github.com/vllm-project/vllm/commit/e962733e08d10f7ca65dac4df99e116460b8b174","https://github.com/vllm-project/vllm/pull/51444","https://github.com/vllm-project/vllm/releases/tag/v0.30.0","https://github.com/vllm-project/vllm/security/advisories/GHSA-2823-qmq8-rwvj"],"products":["vllm:vllm"],"source":"nvd","synced_at":"2026-10-19T22:57:46.668721662+00:00"},"epss":{"cve":"CVE-2026-105756","score":0.00332,"percentile":0.2612,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-2823-qmq8-rwvj","url":"https://osv.dev/vulnerability/GHSA-2823-qmq8-rwvj","summary":"vLLM: Loose `cache_salt` validation lets a single request kill EngineCore on LMCache-MP deployments — uncaught downstream `ValueError` denial of service","modified":"2026-10-15T14:56:10.619436517Z","packages":[{"ecosystem":"PyPI","name":"vllm","purl":"pkg:pypi/vllm","ranges":["<0.30.0"],"fixed":["0.30.0"]}]},{"id":"PYSEC-2026-4306","url":"https://osv.dev/vulnerability/PYSEC-2026-4306","summary":"vLLM: Loose `cache_salt` validation lets a single request kill EngineCore on LMCache-MP deployments — uncaught downstream `ValueError` denial of service","modified":"2026-10-15T14:45:14.714606860Z","packages":[{"ecosystem":"PyPI","name":"vllm","purl":"pkg:pypi/vllm","ranges":["<0.30.0"],"fixed":["0.30.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}