{"cve":"CVE-2025-66448","nvd":{"published":"2025-12-01T23:15:54.213","modified":"2026-10-18T18:10:00.100","status":"Analyzed","description":"vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.11.1, vllm has a critical remote code execution vector in a config class named Nemotron_Nano_VL_Config. When vllm loads a model config that contains an auto_map entry, the config class resolves that mapping with get_class_from_dynamic_module(...) and immediately instantiates the returned class. This fetches and executes Python from the remote repository referenced in the auto_map string. Crucially, this happens even when the caller explicitly sets trust_remote_code=False in vllm.transformers_utils.config.get_config. In practice, an attacker can publish a benign-looking frontend repo whose config.json points via auto_map to a separate malicious backend repo; loading the frontend will silently run the backend’s code on the victim host. This vulnerability is fixed in 0.11.1.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-94"],"references":["https://github.com/vllm-project/vllm/commit/ffb08379d8870a1a81ba82b72797f196838d0c86","https://github.com/vllm-project/vllm/pull/28126","https://github.com/vllm-project/vllm/security/advisories/GHSA-8fr4-5q9j-m8gm"],"products":["vllm:vllm"],"source":"nvd","synced_at":"2026-10-19T22:16:02.354564667+00:00"},"epss":{"cve":"CVE-2025-66448","score":0.0066,"percentile":0.51285,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-8fr4-5q9j-m8gm","url":"https://osv.dev/vulnerability/GHSA-8fr4-5q9j-m8gm","summary":"vLLM vulnerable to remote code execution via transformers_utils/get_config","modified":"2026-07-17T16:30:30.600907369Z","packages":[{"ecosystem":"PyPI","name":"vllm","purl":"pkg:pypi/vllm","ranges":["<0.11.1"],"fixed":["0.11.1"]}]},{"id":"PYSEC-2026-2015","url":"https://osv.dev/vulnerability/PYSEC-2026-2015","summary":"vLLM vulnerable to remote code execution via transformers_utils/get_config","modified":"2026-07-07T17:48:15.884423346Z","packages":[{"ecosystem":"PyPI","name":"vllm","purl":"pkg:pypi/vllm","ranges":["<0.11.1"],"fixed":["0.11.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}