{"cve":"CVE-2025-62164","nvd":{"published":"2025-11-21T02:15:43.193","modified":"2026-10-19T13:10:00.110","status":"Analyzed","description":"vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-20","CWE-123","CWE-502","CWE-787"],"references":["https://github.com/vllm-project/vllm/commit/58fab50d82838d5014f4a14d991fdb9352c9c84b","https://github.com/vllm-project/vllm/pull/27204","https://github.com/vllm-project/vllm/security/advisories/GHSA-mrw7-hf4f-83pf"],"products":["vllm:vllm"],"source":"nvd","synced_at":"2026-10-19T22:16:02.354564667+00:00"},"epss":{"cve":"CVE-2025-62164","score":0.00963,"percentile":0.61411,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-mrw7-hf4f-83pf","url":"https://osv.dev/vulnerability/GHSA-mrw7-hf4f-83pf","summary":"vLLM deserialization vulnerability leading to DoS and potential RCE","modified":"2026-09-10T03:50:58.425031809Z","packages":[{"ecosystem":"PyPI","name":"vllm","purl":"pkg:pypi/vllm","ranges":[">=0.10.2 <0.11.1"],"fixed":["0.11.1"]}]},{"id":"PYSEC-2026-2018","url":"https://osv.dev/vulnerability/PYSEC-2026-2018","summary":"vLLM deserialization vulnerability leading to DoS and potential RCE","modified":"2026-07-07T17:48:16.120884521Z","packages":[{"ecosystem":"PyPI","name":"vllm","purl":"pkg:pypi/vllm","ranges":[">=0.10.2 <0.11.1"],"fixed":["0.11.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}