{"cve":"CVE-2025-57816","nvd":{"published":"2025-09-08T22:15:33.703","modified":"2026-06-17T09:43:29.437","status":"Analyzed","description":"Fides is an open-source privacy engineering platform. Prior to version 2.69.1, the Fides Webserver API's built-in IP-based rate limiting is ineffective in environments with CDNs, proxies or load balancers. The system incorrectly applies rate limits based on directly connected infrastructure IPs rather than client IPs, and stores counters in-memory rather than in a shared store. This allows attackers to bypass intended rate limits and potentially cause denial of service. This vulnerability only affects deployments relying on Fides's built-in rate limiting for protection. Deployments using external rate limiting solutions (WAFs, API gateways, etc.) are not affected. Version 2.69.1 fixes the issue. There are no application-level workarounds. However, rate limiting may instead be implemented externally at the infrastructure level using a WAF, API Gateway, or similar technology.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","score":6.3},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-799"],"references":["https://github.com/ethyca/fides/commit/59903c195e2f9f8915a1db94950aefd557033a5c","https://github.com/ethyca/fides/releases/tag/2.69.1","https://github.com/ethyca/fides/security/advisories/GHSA-fq34-xw6c-fphf"],"products":["ethyca:fides"],"source":"nvd","synced_at":"2026-10-19T22:08:41.295252406+00:00"},"epss":{"cve":"CVE-2025-57816","score":0.00435,"percentile":0.37817,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-fq34-xw6c-fphf","url":"https://osv.dev/vulnerability/GHSA-fq34-xw6c-fphf","summary":"Fides Webserver API Rate Limiting Vulnerability in Proxied Environments","modified":"2026-09-10T03:50:28.364158567Z","packages":[{"ecosystem":"PyPI","name":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","ranges":["<2.69.1"],"fixed":["2.69.1"]}]},{"id":"PYSEC-2026-1341","url":"https://osv.dev/vulnerability/PYSEC-2026-1341","summary":"Fides Webserver API Rate Limiting Vulnerability in Proxied Environments","modified":"2026-07-07T17:46:40.528106089Z","packages":[{"ecosystem":"PyPI","name":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","ranges":["<2.69.1"],"fixed":["2.69.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}