{"cve":"CVE-2025-57164","nvd":{"published":"2025-10-17T18:15:37.013","modified":"2026-06-17T09:42:54.627","status":"Analyzed","description":"Flowise through v3.0.4 is vulnerable to remote code execution via unsanitized evaluation of user input in the \"Supabase RPC Filter\" field.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","score":6.5},"cwes":["CWE-77"],"references":["https://github.com/FlowiseAI/Flowise","https://github.com/FlowiseAI/Flowise/blob/main/packages/components/nodes/vectorstores/Supabase/Supabase.ts#L237","https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-7944-7c6r-55vv"],"products":["flowiseai:flowise"],"source":"nvd","synced_at":"2026-10-19T22:12:35.277909958+00:00"},"epss":{"cve":"CVE-2025-57164","score":0.00637,"percentile":0.50558,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-7944-7c6r-55vv","url":"https://osv.dev/vulnerability/GHSA-7944-7c6r-55vv","summary":"FlowiseAI Pre-Auth Arbitrary Code Execution","modified":"2025-10-17T20:44:44.249658Z","packages":[{"ecosystem":"npm","name":"flowise","purl":"pkg:npm/flowise","ranges":[">=3.0.5 <3.0.6"],"fixed":["3.0.6"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}